Activating Heavy 6.0

Hi! We have OmniSci 5.x installed. How can be upgrade it to 6.0? Do we need to reinstall? Thanks!

Hi @HAPPY,

We had to rebrand the product, so the upgrade path was to remove the old product and install the new one.
If you plan to use the same storage path, the new software will automatically upgrade the database.

if you are using APT and services, please follow those steps

You have to run the install_heavy_systemd.sh script to re-install the services.

The database’s upgrade wouldn’t create any issue, but I suggest taking a backup if you need, for whatever reason, to fall back to a previous release.

Best Regards,
Candido

Hi, @candido.dessanti, I followed the instructions in the above link. However, I got stuck here. My system is CentOS 7, and we want to upgrade OmniSci 5.x to heavyai 6.

when I try to install the heavyai bysudo yum install heavyai-ee-cuda, it says no package heavyai-ee cuda available, see the screen shot below,

Hi @Xiaokang_Fu,

I’m assuming you have already removed the version 5 of OmnisciDB.

To install the 6.0, I ran this command

sudo yum install heavyai.x86_64

Try with this, because probably we have the wrong version of docs.

Regards,
Candido

1 Like

@candido.dessanti Great. That works. I have another problem after this. I follow this for upgrading. I got stuck when I run

sudo systemctl start heavyai_server
sudo systemctl start heavy_web_server

I got errors here,

Note that the ./install_heavy_systemd.sh run without errors.

Hi,

I guess you have solved the issue yet.

the correct command is

sudo systemctl start heavydb

Candido.

p.s. We know the docs are inconsistent; they are getting a significant overhaul.

Thanks for the reply. I changed to using docker to install it.

Hi,

In the meanwhile we have almost rewritten all the installation docs :wink:

1 Like