Black screen when accessing omnisci through ssh tunnel

I am installing omnisci from tarball following those instructions : Ubuntu Enterprise/Free Editions GPU with Tarball - OmniSci Docs

The only difference is that I created an ssh tunnel so I can access the omnisci server from my laptop
at localhost:6273

However i do get a black screen. The browser debugger indicates :

bundle.260c762a0c327bf33b819f53bfb5ad253046e9a4.js:1 Could not reach host
Uncaught (in promise) Error: Connection error when fetching license

So i imagine the urls to the backend are expected to map to the public interfaces.
Is there a way to alter omnisci frontend configuration to modify the backend url so it can point to another location (in my case localhost)?

Thanks for your help!

Hi Antoine,

Welcome to our community.

I guess that as default our webserver is using the address you used for the tunneling to access the database (to fetch license in this case) to contact the database.

The database is running on port 6278 with Immerse, so I would try to tunnel the localhost on port 6278.

I this isn’t working you can try to use to use the backend-Url parameter on omnisci.conf on webserver section.


Thank you Candido, setting the backend url solved my issue.

For reference, configuration options can be found here :

And checking the server logs helped single out the problem :
journalctl -xn -u omnisci_web_server | tail -n10

1 Like

I’m happy that’s solved the problem for your configuration, and I’m extremely grateful for the reference to the docs and the command you reported and that will help other people to troubleshoot their installation