Export after lasso tool does not reflect the drawn boundaries

hello,

I am Stefano, a daily user of your dashboard.
We are here at Harvard and the BIDMC campus in Boston.
We are collaborating with HEAVY.AI on big genomic data visualization.

When I export the data from a chart, I notice that the lasso option does not give you the spots or polygons inside the boundaries (see fig bottom left and bottom right) but the one inside the square. So, for instance, the green polygons should be neither in the donuts plot nor in the main choropleth plot.
Thanks in advance for your help.

Kind Regards,
SN

1 Like

Hi @stefanonard85,

So when you export any chart from the dashboard the cross filter is using the bounding box in the point map to export your data while, at the same time, the dashboard navigation is using the coordinates inside the lasso?

Edit: I tried to reproduce the issues, but when I tried to export the data it was filtered with regulòar boundaries

so using this filter

I get the correct results.

I’m able to reproduce the issue only by creating an additional layer of the map and then creating the lasso filter on top of that. This way the points in the underlying layer are filtered by the bounding box

Are you using more than one layer in your map?

Best Regards,
Candido

hello Candido,

Thanks for your reply. Yes, I ma using two layers in my map. A choropleth and a point map.
I guess choropleth map does not have the lasso option.
Have a nice day

Hi Stefano,

so you have a layer 0 with a CP Map and a layer 1 with a Point Map?

This way is working. but maybe you are doing the opposite. So the workaround is switching the order of the layers

hello Candido,

It seems like this will work.
Thx a lot for the help is much appreciated.
Have a nice day.

1 Like

Hi @stefanonard85,

I’m happy that the workaround is working, I’ll report the Immerse behaviour to the front-end team.

Regards,
Candido