Failed to start omnisci_web Don´t know where is the issue

Hi,

I was installing in a dedicated server UBUNTU 20. with GPU and a TESLA K80 ( server recognize tesla and looks like there is no issue with it).

I was in the last steps and when execute:
sudo systemctl start omnisci_web_server

I receive this message:

Failed to start omnisci_web_server.service: Unit omnisci_web_server.service not found.

So i have no clue where the the problem could be.
Any help will be great!! many thanks in advance

Hi @Juan_Pablo_Sanchez,

Have you successfully run the install_omnisci_systemd.sh command in the directory where you installed omnisci software?

You can check if you have omnisci’s services installed into the system with a simple ls command.

mapd@zion-tr:/opt/mapd/omnisci-ee-5.10.0-20220107-8939c3b1c4-Linux-x86_64-render/systemd$ sudo ls -la /lib/systemd/system/omnisci*
-rw-r--r-- 1 root root 427 giu 30  2019 /lib/systemd/system/omnisci_sd_server.service
-rw-r--r-- 1 root root 437 giu 30  2019 /lib/systemd/system/omnisci_sd_server@.service
-rw-r--r-- 1 root root 457 giu 30  2019 /lib/systemd/system/omnisci_server.service
-rw-r--r-- 1 root root 467 giu 30  2019 /lib/systemd/system/omnisci_server@.service
-rw-r--r-- 1 root root 411 giu 30  2019 /lib/systemd/system/omnisci_web_server.service
-rw-r--r-- 1 root root 421 giu 30  2019 /lib/systemd/system/omnisci_web_server@.service

If not, try to re-run the initialization script

I hope this will solve the malfunction, anyway, feel free to come back here if not.

Regards,
Candido

Hi sorry, it didnt work so i understand i´m doing in somepoint a rong step.

I just re-install all and notice that the UBUNTU OPEN SOURCE GPU with Tarball instructions are without the systemctl start omnisci_web_server COMMAND.

Not sure why?
What i will like to install is the GPU versión for web access with a R730 UBUNTU 20.04 and a TESLA K80.

here is the tesla.

any help will be appreciate it

Hi @Juan_Pablo_Sanchez,

you can start our server in several ways, and one of them is installing the databases and Immerse as services

to enable them, you have to run the script located into the installation path under the systemd directory called install_omnisci_systemd.sh.

so log in to the server move into the directory you installed the product and run the shell this way

mapd@zion-tr:/opt/mapd/omnisci-ee-5.10.0-20220107-8939c3b1c4-Linux-x86_64-render/systemd$ sudo ./install_omnisci_systemd.sh
OMNISCI_PATH: OmniSci install directory
[/opt/mapd/omnisci-ee-5.10.0-20220107-8939c3b1c4-Linux-x86_64-render]: 

OMNISCI_STORAGE: OmniSci data and configuration storage directory
[/var/lib/omnisci]: 

OMNISCI_USER: user OmniSci will be run as
[root]: mapd

OMNISCI_GROUP: group OmniSci will be run as
[root]: mapd

OMNISCI_PATH:	/opt/mapd/omnisci-ee-5.10.0-20220107-8939c3b1c4-Linux-x86_64-render
OMNISCI_STORAGE:	/var/lib/omnisci
OMNISCI_USER:	mapd
OMNISCI_GROUP:	mapd

this will install both the services that will be run by the user mapd and will store the data into the /var/lib/omnisci directory.
Of course this is just an example, you can choose the directory and the user you prefer.

to be sure everything has been installed just run this command

mapd@zion-tr:/opt/mapd/omnisci-ee-5.10.0-20220107-8939c3b1c4-Linux-x86_64-render/systemd$

systemctl list-unit-files | grep omnisci
omnisci_sd_server.service                          disabled        enabled      
omnisci_sd_server@.service                         disabled        enabled      
omnisci_server.service                             disabled        enabled      
omnisci_server@.service                            disabled        enabled      
omnisci_web_server.service                         disabled        enabled      
omnisci_web_server@.service                        disabled        enabled

not you can start the services with systemctl omnisci_server start and/or systemctl omnisci_web_server start (you have to start both of them because the webserver uses the database server for authentication, rendering of maps and querying that data).

you can also start the database and the web server from shell with the startomnisci command this way

mapd@zion-tr:/opt/mapd/omnisci-ee-5.10.0-20220107-8939c3b1c4-Linux-x86_64-render$ ./startomnisci
startomnisci 477537 running
Backend TCP:  localhost:6274
Backend HTTP: localhost:6278
Frontend Web: localhost:6273
Calcite TCP:  localhost:6279
- omnisci_server 477547 started
- omnisci_web_server 477548 started
⇨ http server started on [::]:6273

this would spawn both the database and the webserver.

On both cases, on the first time you run the application If you are using the free edition or a trial of enterprise, you should login to the webserver on port 6273 and paste the license you received by email

Hope this helps.

Candido

p.s. nVidia dropped the support for the Tesla K80 starting with 495 driver

Hi and thanks for the help! unfurtunatly i can replicate your steps.
Please see what i have instead.

HI,

I’m sorry, I forgot to post the commands needed to start services using systemctl

to start the database you have to run

sudo systemctl start omnisci_server 

and for the omnisci web server

sudo systemctl start omnisci_web_server

Let me know, if everything is ok,
candido