GPU Error - Chart Redraw Error - Vulkan

Hello,

we want do build a tweet map as an project during an university semesters course.

We installed the free version with GPU and tar (Ubuntu Enterprise/Free Editions GPU with Tarball - HEAVY.AI Docs).

We can acess Immerse an load Data. We can visualize the Data on “non-GPU” panels.
If we want to use a map or other GPU dependent panels it gives us this error.

It shows up as an popup in Immerse:

“Chart Redraw Error
OutOFGpuMemoryError: Error allocating device memory: Vulkan Error:
VK_ERROR_OUT_OF_DEVICE_MEMORY - /home/jenkins-slave/workspace/
mapd2-multi/compiler/gcc/host/centos7-cuda-x86_64/render/render/
GfxDriver/Drivers/Vulkan/VulkanMemoryMgr.cpp:119”

This is the output of “systemctl status hevydb”:

heavydb.service - HEAVY.AI HeavyDB database server
Loaded: loaded (/lib/systemd/system/heavydb.service; enabled; vendor preset: enabled)
Active: active (running) since Sat 2022-05-21 13:42:32 UTC; 2min 34s ago
Main PID: 6718 (heavydb)
Tasks: 53 (limit: 18962)
Memory: 415.2M
CGroup: /system.slice/heavydb.service
├─6718 /opt/heavyai-installs/heavyai-ee-6.0.0-20220418-d4d1c2a42c-Linux-x86_64-render/bin/heavydb --config /var/lib/heavyai/heavy.conf
└─6758 -Xmx1024m -DLOG_DIR=/var/lib/heavyai/storage/log/ -jar /opt/heavyai-installs/heavyai-ee-6.0.0-20220418-d4d1c2a42c-Linux-x86_64-render/bin/calcite-1.0-SNAPSHOT-jar-with-dependencies.jar -e /opt/heavyai-installs/>

May 21 13:42:32 dk49 systemd[1]: Started HEAVY.AI HeavyDB database server.
May 21 13:44:05 dk49 heavydb[6718]: 2022-05-21T13:44:05.148104 E 6718 0 2 GlobalRenderContext.cpp:435 GPU 0 has incomplete ID PBO Pool
May 21 13:44:05 dk49 heavydb[6718]: 2022-05-21T13:44:05.148280 E 6718 0 2 GlobalRenderContext.cpp:113 Render resources and caches incomplete, unable to render
May 21 13:44:05 dk49 heavydb[6718]: 2022-05-21T13:44:05.156484 E 6718 0 2 DBHandler.cpp:4673 OutOfGpuMemoryError: Error allocating device memory: Vulkan Error: VK_ERROR_OUT_OF_DEVICE_MEMORY - /home/jenkins-slave/workspace/mapd2-mu>

Our GPU is small! (2GB) but i tried it with 4kB of Data (4 Koordinates in geojson format) and its still the same problem.

Could someone please help me!?!

Lukas

Hi Lukas,

Thanks for joining our community.

You are getting this error because when the first query is run the memory manager allocates the first slab in the GPU memory exhausting it. The renderer cannot use the memory in the cache so it’s raising this exception.

To solve the problem you must limit the amount of memory available to the memory manager for the caches using the gpu-buffer-mem-bytes parameter.

Assuming you are using the system, you have to change the /var/lib/heavyai/heavy.conf appending this line
gpu-buffer-mem-bytes=1200000000
in the first section. The memory avaiable to MM will be reduced more or less to 1.2GB

port = 6274
http-port = 6278
calcite-port = 6279
data = "/var/lib/heavyai/storage"
null-div-by-zero = true
gpu-buffer-mem-bytes=1200000000

[web]
port = 6273
frontend = "/opt/mapd/heavyai-ee-6.0.0-20220418-d4d1c2a42c-Linux-x86_64-render/frontend"

then you should restart the server with the command
systemctl restart hevydb

This should make the renderer work, but the amount of data that the database will be able to process on GPU will be reduced.

Let me know if this solution is working for you, if not we will try something different.

Regards,
Candido

Hi Candido,

I owe you something. It worked perfectly!

Thank you very much.

Regards,
Lukas