The latest version of MapDExample?

I am currently working on MapDExample.cs.

To perform MapDExample.cs

  1. Change to all MapD → OmniSci in code.
  2. For cs files that need to be added, we added the trift file of the omniscidb-master by converting it to a cs file.
  3. For nuget packages, apache thrift 0.10.0 was installed to add packages.

After completing the above procedure, you could use omnisci_serv by remote connection.

Currently, if you want to use MapDExample.cs for the above process, installing nuget package 0.110.0 is mandatory.0.

For the current nuget package, it has been up to 0.14.0 recently. I want to perform MapDExample using the latest version of nuget package.

MapDExample.cs is the latest update from two years ago.
Maybe that’s why it only supports 0.10.0 version.

We would appreciate it if you have the latest version of the MapDExample.cs code or have a solution.

You might ask why I use MapDExample.cs.
I want to study sql with csharp.

I would appreciate it if you let me know if there is a solution.


I think the MapDExample.cs isn’t up to date, but I’m not sure why it isn’t working with the new version of thrift; probably come methods of thrift are changed. which errors are you getting?


Thank you for replying.

Entering the command “thrift -gen csharp omnisci.thrift” in cmd using thrift-0.14.0 or 0.10.0 does not cause problems in converting the .thrift file to obtain the .cs file.

If you convert all .thrift files currently present in omniscidb-master to .cs files and add them to the project, you will receive an error that usingthrift is not available.

To resolve the above error, we installed the latest version of apachethrift (.NET Library) in nuget package management as our first attempt.
As a result, an error like the picture below occurred.

I am trying to find a cs file that corresponds to THttpClient, TJSONProtocl, etc. where the error occurred to solve the error.We found that a corresponding .cs file exists in the tar.gz folder.
You have added the file to a project in visual. I solved some errors, but there were still some errors left.

During various attempts, we found that the apachethrift (.NET Library) in the nuget package also had a version 0.10.0.
If you install the corresponding version of the nuget package, you can see that you can resolve and execute the error.

If the update continues, the old version of 0.10.0 will disappear. And I asked you a question because I wanted to proceed with the project using the latest version, not the old one.

If you have any good opinions on this, please.

And there is a great way to deal with sql like jdbc for java and python for pymapd.
In the case of chsarp, wouldn’t the above?

Hi @g_star,

I successfully compiled the example using thrift from NuGet. I had some trouble while generating the thrift files, so I had to move the contents of the includes into iìomnisci.thfith.

I used the because actually, the dependencies are using this version

Installing .net framework 4.7 I have been able to install apache thrift 0.14, but it doesn’t support the csharp anymore, and the netstd generated is full of errors; anyway, I think you should go with the actual dependencies used to compile the database.

I tried (as you did I guess) to generate the csharp files with thrifth-0.13, using with 0.14 but it’s not going to work; it’s not a problem of omnisci thrifth but it’s the thrift itself that hasn’t the binding for c# anymore

so you should switch to .net standard, if you want to use the 0.14 on windows