Thrift Connection refused


I followed the step of Ubuntu Open Source GPU with Tarball to install Omnisci on Ubuntu GPU instance.But when I wanted to load some sample data and perform an omnisql query, I encountered some mistakes as below:

I ran the code

>sudo ./insert_sample_data

When prompted, I entered 2 to insert the 10 thousand row flights dataset. But the output was like this:

-adding schema
Thrift: Fri Jan 29 21:54:51 2021 TSocket::open() connect() <Host: localhost Port:6274>: Connection refused
Thrift: Fri Jan 29 21:54:51 2021 TSocket::open() connect() <Host: localhost Port:6274>: Connection refused
Failed to open transport. Is omnisci_server running?

Then, I ran the following code:


After I input the password, it outputs

Thrift: Fri Jan 29 22:08:16 2021 TSocket::open() connect() <Host: localhost Port:6274>: Connection refused
Thrift: Fri Jan 29 22:08:16 2021 TSocket::open() connect() <Host: localhost Port:6274>: Connection refused
Failed to open transport. Is omnisci_server running?

It seems I can’t connect to the server, but the server is already running

omnisci_server.service - OmniSci database server
Loaded: loaded (/lib/systemd/system/omnisci_server.service; enabled; vendor preset: enabled)
Active: active (running) since Fri 2021-01-29 22:42:34 CST; 673ms ago
Main PID: 45979 (omnisci_server)
Tasks: 7
Memory: 14.8M
CPU: 425ms
CGroup: /system.slice/omnisci_server.service
└─45979 /opt/omnisci/bin/omnisci_server --config /var/lib/omnisci/omnisci.conf

My system is Ubuntu 16.04, and I use 8 Tesla V100-PCIEs as my gpu. There are some schoolfellows using these gpus too, does this affect?


Hi @earyj,

Welcome to the community forum :wink:

Obviously, the server isn’t running, or it’s not running on the default port (6274), or there is some other issue.

The Tesla V100-PCI-E works flawlessly with our database, so that the problem could be in the driver (or in the combo Driver and OS)

The service status looks the server has started since 673ms only, so maybe it’s crashed and restored by the system.

You can try to stop the service and start from the command line.

sudo service omnisci_server stop
/opt/omnisci/bin/omnisci_server --config /var/lib/omnisci/omnisci.conf

Check if there are some errors, and please report back.

You can also try to tea a look at the log files that are located under /var/lib/omnisci/mapd_logs
and check for the latest

lrwxrwxrwx 1 root root       39 gen 29 16:25 omnisci_server.INFO -> omnisci_server.INFO.20210129-162532.log
lrwxrwxrwx 1 root root       42 gen 29 16:33 omnisci_server.WARNING -> omnisci_server.WARNING.20210129-163307.log
lrwxrwxrwx 1 root root       40 gen 29 16:33 omnisci_server.ERROR -> omnisci_server.ERROR.20210129-163307.log

To be sure you are using a suitable driver, please post the output of the nvidia-smi command.
The 5.5 release as a minimum requirement of the driver version 450.xx

| NVIDIA-SMI 450.102.04   Driver Version: 450.102.04   CUDA Version: 11.0     |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr: Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|   0  GeForce RTX 208...  Off  | 00000000:09:00.0 Off |                  N/A |
| 58%   81C    P5   132W / 250W |  10841MiB / 11019MiB |      0%      Default |
|                               |                      |                  N/A |
|   1  GeForce RTX 208...  Off  | 00000000:0A:00.0 Off |                  N/A |
| 72%   87C    P5    99W / 260W |  10841MiB / 11019MiB |      0%      Default |
|                               |                      |                  N/A |
|   2  GeForce RTX 208...  Off  | 00000000:43:00.0 Off |                  N/A |
| 50%   76C    P5   121W / 250W |    370MiB / 11019MiB |      0%      Default |
|                               |                      |                  N/A |

| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|    0   N/A  N/A     62099      C   ...RIBUTE/bin/omnisci_server    10801MiB |
|    1   N/A  N/A     62099      C   ...RIBUTE/bin/omnisci_server    10801MiB |
|    2   N/A  N/A      1980      G   /usr/lib/xorg/Xorg                105MiB |
|    2   N/A  N/A      2565      G   /usr/bin/gnome-shell               58MiB |
|    2   N/A  N/A     62099      C   ...RIBUTE/bin/omnisci_server      165MiB |

Best regards,

Sorry for replying late.

My fault. I didn’t read the requirements carefully. The output of nvidia-smi is as below

So it seems that the mistake is because the driver and cuda version don’t meet the requirements. But I can’t upgrade them as there are others using the server in the meantime.

I want to use the former MapD version that matches the driver version. Though I do find the documents of the former release, the download link always points to the latest version :joy:

May I aquire the fomer CE version?

1 Like


Don’t worry.

I will provide a link to the newest OS version that would run with such old driver; It’s the 5.1.2. Quite old, but new enough to get you an idea about the software.

you can download at this link

or If you prefere you can install the same version using apt (but I’m not sure if you have administrative privileges, and they are needed to do that)

to add the repository

curl | sudo apt-key add -
echo "deb stable cuda" | sudo tee /etc/apt/sources.list.d/omnisci.list
sudo apt update

to list the releases

root@zion-legion:/opt# apt list omnisci -a
Elencazione... Fatto
omnisci/stable 5.5.1-20210126-84edb9bd7b amd64 [aggiornabile da: 5.1.2-20200304-e118922084]
omnisci/stable 5.5.0-20210108-24e3c06ae7 amd64
omnisci/stable 5.4.1-20200928-3d17eec6c1 amd64
omnisci/stable 5.4.0-20200908-7002f5efb7 amd64
omnisci/stable 5.3.2-20200803-a970373210 amd64
omnisci/stable 5.3.1-20200709-e05cbb53ba amd64
omnisci/stable 5.3.0-20200617-a1f391c2a4 amd64
omnisci/stable 5.2.2-20200518-7e9a996c75 amd64
omnisci/stable 5.2.1-20200422-73d21fc594 amd64
omnisci/stable,5.1.2-20200304-e118922084 amd64
omnisci/stable 5.1.1-20200226-19f49e20cf amd64
omnisci/stable 5.1.0-20200211-bc790105fb amd64
omnisci/stable 5.0.1-20191118-4c7b6d5ad6 amd64
omnisci/stable 5.0.0-20191115-02c03d47a5 amd64
omnisci/stable 4.8.1-20190903-e9ac6920a3 amd64
omnisci/stable 4.8.0-20190807-2f7a6bdf52 amd64
omnisci/stable 4.7.1-20190628-5bae2da063 amd64
omnisci/stable 4.7.0-20190614-4559864637 amd64
omnisci/stable 4.6.1-20190501-1937c23915 amd64
omnisci/stable 4.6.1-20190430-911b026323 amd64
omnisci/stable 4.6.0-20190415-38f897c50e amd64
omnisci/stable 4.5.0-20190221-e41be43ff0 amd64

and then to install 5.1.2

apt install omnisci=5.1.2-20200304-e118922084

you will find the installation on /opt/omnisci

Let me know if everything is ok, andd come back to the forum if you need assistance trying the software :wink:

Best Regards,

hah…I actually don’t have privileges, so I installed with tarball :rofl:

Now everything is ok, thanks a lot!

1 Like


have fun wth our database, and come bnack to the forum for whatever you need.